You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
[Snyk] Security upgrade webpack-dev-server from 4.15.2 to 6.0.0 - #3346
This is a major version upgrade from webpack-dev-server v4 to v5, which introduces significant breaking changes requiring configuration and environment updates. The target version 6.0.0 has not been released; this analysis covers the upgrade to the v5.x line.
Key Breaking Changes (v4 → v5):
Environment Requirements:
Node.js: The minimum required Node.js version is now 18.12.0.
webpack: The minimum required webpack version is 5.0.0.
Configuration (webpack.config.js):
Server Options: The https and http2 options have been removed. You must migrate your HTTPS configuration to the new server object.
Proxy Configuration: The proxy option syntax has changed from an object to an array of objects. This will require refactoring any existing proxy setup.
Node.js API: For users of the Node.js API, the constructor arguments have been swapped from new Server(compiler, options) to new Server(options, compiler).
Removed Options: The magicHtml option has been removed entirely.
Recommendation: Developers must carefully review the official migration guide and update their webpack.config.js and Node.js environment. The changes to server and proxy configuration are mandatory and will break existing setups.
Notice 🤖: This content was augmented using artificial intelligence. AI-generated content may contain errors and should be reviewed for accuracy before use.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Snyk has created this PR to fix 1 vulnerabilities in the npm dependencies of this project.
Snyk changed the following file(s):
ui/package.jsonui/package-lock.jsonVulnerabilities that will be fixed with an upgrade:
SNYK-JS-OPEN-22112123
Breaking Change Risk
Important
Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open fix PRs.
For more information:
🧐 View latest project report
📜 Customise PR templates
🛠 Adjust project settings
📚 Read about Snyk's upgrade logic
Learn how to fix vulnerabilities with free interactive lessons:
🦉 Learn about vulnerability in an interactive lesson of Snyk Learn.